| Commit message (Expand) | Author | Age |
* | arch: Mass conversion of smp_mb__*() | Peter Zijlstra | 2014-04-18 |
* | bitops: Fix signedness of compile-time hweight implementations | Paul Walmsley | 2014-02-09 |
* | bitops/find: clarify and extend documentation | Cody P Schafer | 2013-11-12 |
* | Merge branch 'modules-next' of git://git.kernel.org/pub/scm/linux/kernel/git/... | Linus Torvalds | 2012-10-14 |
|\ |
|
| * | MPILIB: Provide count_leading/trailing_zeros() based on arch functions | David Howells | 2012-10-07 |
* | | bitops: introduce generic {clear,set}_bit_le() | Takuya Yoshikawa | 2012-10-05 |
* | | generic: Implement generic ffs/fls using __builtin_* functions | Catalin Marinas | 2012-09-14 |
|/ |
|
* | Add #includes needed to permit the removal of asm/system.h | David Howells | 2012-03-28 |
* | asm-generic: add another generic ext2 atomic bitops | Akinobu Mita | 2011-07-26 |
* | bitops: add #ifndef for each of find bitops | Akinobu Mita | 2011-05-26 |
* | bitops: remove minix bitops from asm/bitops.h | Akinobu Mita | 2011-03-23 |
* | bitops: remove ext2 non-atomic bitops from asm/bitops.h | Akinobu Mita | 2011-03-23 |
* | asm-generic: use little-endian bitops | Akinobu Mita | 2011-03-23 |
* | bitops: introduce little-endian bitops for most architectures | Akinobu Mita | 2011-03-23 |
* | asm-generic: change little-endian bitops to take any pointer types | Akinobu Mita | 2011-03-23 |
* | asm-generic: rename generic little-endian bitops functions | Akinobu Mita | 2011-03-23 |
* | bitops: merge little and big endian definisions in asm-generic/bitops/le.h | Akinobu Mita | 2011-03-23 |
* | bitops: remove duplicated extern declarations | Akinobu Mita | 2010-10-09 |
* | bitops: make asm-generic/bitops/find.h more generic | Akinobu Mita | 2010-10-09 |
* | arch, hweight: Fix compilation errors | Borislav Petkov | 2010-05-04 |
* | x86: Add optimized popcnt variants | Borislav Petkov | 2010-04-06 |
* | bitops: Optimize hweight() by making use of compile-time evaluation | Peter Zijlstra | 2010-04-06 |
* | locking: Convert __raw_spin* functions to arch_spin* | Thomas Gleixner | 2009-12-14 |
* | locking: Convert raw_spinlock to arch_spinlock | Thomas Gleixner | 2009-12-14 |
* | asm-generic: rename atomic.h to atomic-long.h | Arnd Bergmann | 2009-06-11 |
* | x86, generic: mark complex bitops.h inlines as __always_inline | Andi Kleen | 2009-01-13 |
* | bitops: use __fls for fls64 on 64-bit archs | Alexander van Heukelum | 2008-04-26 |
* | generic: introduce a generic __fls implementation | Alexander van Heukelum | 2008-04-26 |
* | x86, generic: optimize find_next_(zero_)bit for small constant-size bitmaps | Alexander van Heukelum | 2008-04-26 |
* | ext4: Add ext4_find_next_bit() | Aneesh Kumar K.V | 2008-01-28 |
* | define first set of BIT* macros | Jiri Slaby | 2007-10-19 |
* | bitops: introduce lock ops | Nick Piggin | 2007-10-18 |
* | sched: simplify sched_find_first_bit() | Mike Galbraith | 2007-07-09 |
* | Fix misspellings collected by members of KJ list. | Robert P. J. Day | 2007-05-09 |
* | [PATCH] sched: likely profiling | Nick Piggin | 2006-10-11 |
* | [PATCH] bitops: generic minix_{test,set,test_and_clear,test,find_first_zero}_... | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic ext2_{set,clear}_bit_atomic() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic ext2_{set,clear,test,find_first_zero,find_next_zero}_... | Akinobu Mita | 2006-03-26 |
* | [PATCH] fix error: __u32 undeclared | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic hweight{64,32,16,8}() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic ffs() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic sched_find_first_bit() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic find_{next,first}{,_zero}_bit() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic fls64() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic fls() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic ffz() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic __ffs() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic __{,test_and_}{set,clear,change}_bit() and test_bit() | Akinobu Mita | 2006-03-26 |
* | [PATCH] bitops: generic {,test_and_}{set,clear,change}_bit() | Akinobu Mita | 2006-03-26 |