diff options
author | Ingo Molnar <mingo@elte.hu> | 2011-03-18 05:38:53 -0400 |
---|---|---|
committer | Ingo Molnar <mingo@elte.hu> | 2011-03-18 05:39:00 -0400 |
commit | 8dd8997d2c56c9f248294805e129e1fc69444380 (patch) | |
tree | 3b030a04295fc031db98746c4074c2df1ed6a19f /tools/perf/util/setup.py | |
parent | 1eda75c131ea42ec173323b6c34aeed78ae637c1 (diff) | |
parent | 016aa2ed1cc9cf704cf76d8df07751b6daa9750f (diff) |
Merge branch 'linus' into x86/urgent
Merge reason: Merge upstream commits to avoid conflicts in upcoming patches.
Signed-off-by: Ingo Molnar <mingo@elte.hu>
Diffstat (limited to 'tools/perf/util/setup.py')
-rw-r--r-- | tools/perf/util/setup.py | 19 |
1 files changed, 19 insertions, 0 deletions
diff --git a/tools/perf/util/setup.py b/tools/perf/util/setup.py new file mode 100644 index 00000000000..e24ffadb20b --- /dev/null +++ b/tools/perf/util/setup.py | |||
@@ -0,0 +1,19 @@ | |||
1 | #!/usr/bin/python2 | ||
2 | |||
3 | from distutils.core import setup, Extension | ||
4 | |||
5 | perf = Extension('perf', | ||
6 | sources = ['util/python.c', 'util/ctype.c', 'util/evlist.c', | ||
7 | 'util/evsel.c', 'util/cpumap.c', 'util/thread_map.c', | ||
8 | 'util/util.c', 'util/xyarray.c', 'util/cgroup.c'], | ||
9 | include_dirs = ['util/include'], | ||
10 | extra_compile_args = ['-fno-strict-aliasing', '-Wno-write-strings']) | ||
11 | |||
12 | setup(name='perf', | ||
13 | version='0.1', | ||
14 | description='Interface with the Linux profiling infrastructure', | ||
15 | author='Arnaldo Carvalho de Melo', | ||
16 | author_email='acme@redhat.com', | ||
17 | license='GPLv2', | ||
18 | url='http://perf.wiki.kernel.org', | ||
19 | ext_modules=[perf]) | ||