aboutsummaryrefslogtreecommitdiffstats
path: root/tools/perf/util/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'tools/perf/util/setup.py')
-rw-r--r--tools/perf/util/setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/perf/util/setup.py b/tools/perf/util/setup.py
new file mode 100644
index 000000000000..496d7f432fb8
--- /dev/null
+++ b/tools/perf/util/setup.py
@@ -0,0 +1,18 @@
1#!/usr/bin/python2
2
3from distutils.core import setup, Extension
4
5perf = Extension('perf',
6 sources = ['util/python.c', 'util/ctype.c', 'util/evlist.c',
7 'util/evsel.c', 'util/cpumap.c', 'util/thread_map.c',
8 'util/util.c', 'util/xyarray.c'],
9 include_dirs = ['util/include'])
10
11setup(name='perf',
12 version='0.1',
13 description='Interface with the Linux profiling infrastructure',
14 author='Arnaldo Carvalho de Melo',
15 author_email='acme@redhat.com',
16 license='GPLv2',
17 url='http://perf.wiki.kernel.org',
18 ext_modules=[perf])