|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Tracing and Debugging filenames in Litmus were a bit clumsy. Particularly
it was not immediate to tell the content of a tracing/debugging file from
its name, and it was not intuitive to navigate through the CONFIG
macros. This commit refactors tracing/debugging filenames and the
corresponging CONFIG macros to more intuitive names.
Overhead Tracing (employs Feather Trace):
renamed: include/litmus/trace.h -> include/litmus/sched_trace_ohead.h
renamed: litmus/trace.c -> litmus/sched_trace_ohead.c
Scheduling-related tracing (employs Feather Trace):
renamed: include/litmus/sched_trace.h -> include/litmus/sched_trace_task.h
renamed: litmus/sched_task_trace.c -> litmus/sched_trace_task.c
Debugging (TRACE() macro):
renamed: litmus/sched_trace.c -> litmus/debug_trace.c
|